Incidents

Issue with printing

resolvedMEDIUMaffectedPrintinglasted 14h 2min 22s

Root cause: The issue was caused by an unplanned update of the MS Edge browser component on the backend environment on Friday, 3 July 2026 . We relied on MS edge for pdf/print operations, but the updated version of MS Edge had some regressions related to this and therefore the pdf/print process was impacted. Mitigation: To ensure we are not relying on this component going forward, we updated our systems to instead rely on a stable version of Chrome, where we are in full control of which version is deployed and when. This fixed the issue. We have now also added specific monitoring of the pdf generation process to ensure that we will discover similar issues more quickly in the future.

resolved
Jul 7 09:31:55 (UTC)

The issue has been resolved.

resolved
Jul 6 21:03:20 (UTC)

We are still monitoring the fix as it is being deployed to customer environments. All environments upgraded so far behave as expected with the fix successfully resolving the issue.

monitoring
Jul 6 20:28:52 (UTC)

A fix has been implemented and we are monitoring the results as the fix is being deployed to customer environments.

monitoring
Jul 6 19:29:01 (UTC)

The issue has been identified and we are working on a fix. The fix has successfully been deployed to our development platform and has been verified to resolve the issue. We will begin deploying the fix to customer environments shortly.

identified
Jul 6 16:52:01 (UTC)

We are still investigating the issue. The verification of the fix will take a while. We will publish an update later today, but not as regularly as earlier.

investigating
Jul 6 14:13:24 (UTC)

We are still investigating the issue. A fix is being deployed to our development platform after which we will determine whether the fix permanently resolves the issue.

investigating
Jul 6 13:21:27 (UTC)

We are still investigating the issue. Findings so far indicate that a security update from Microsoft has changed the printing environment. We are investigating how to mitigate the changes.

investigating
Jul 6 11:25:17 (UTC)

We are still investigating the issue, but otherwise have no news to share.

investigating
Jul 6 10:54:25 (UTC)

We are still investigating the issue. We are able to consistently reproduce the issue, but have not yet identified the root cause.

investigating
Jul 6 09:55:45 (UTC)

We are still investigating the issue. The issue impacts all printing operations, which means printing of order details is also impacted.

investigating
Jul 6 07:39:58 (UTC)

There are currently issues with printing using the Concierge 365 platform. This impacts guest card printing. We are currently investigating the issue.

investigating
Jul 6 07:00:58 (UTC)